Version française
Home     About     Download     Resources     Contact us    
Browse thread
Teaching ocaml programming
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Erik de Castro Lopo <mle+ocaml@m...>
Subject: Re: [Caml-list] Teaching ocaml programming
Arthur Chan wrote:

> Btw, I wouldn't try to use OCaml with Ubuntu,

I find the Ocaml support on Ubuntu to be excellent. This is mainly
due to the hard word of the Debian Ocaml maintainers.

> Support is generally flaky.

Sorry, thats not my experience.

> The mainline OCaml that comes with Ubuntu is fine, but the gl+gtk
> support is broken.

Use both lablgl and lablgtk (but not together) without problems.

What exactly is broken. Have you logged a bug with Ubuntu or with
the Debian Ocaml maintainers.

> version of Eclipse that ships with Ubuntu is freaking ancient and won't
> support the Scala plugin.  From what I remember, 8.0.4 also shipped with
> some fossilized version of Scala itself.

I don't use Scala or Eclipse so I can't comment on that.

Erik
-- 
-----------------------------------------------------------------
Erik de Castro Lopo
-----------------------------------------------------------------
"If you need a piece of paper and a pen to explain it, 
then its not bleedin' obvious" -- Erik's First Law