Version française
Home     About     Download     Resources     Contact us    
Browse thread
OCaml version 3.11.0+beta1
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Andres Varon <avaron@g...>
Subject: Re: [Caml-list] OCaml version 3.11.0+beta1

On Oct 15, 2008, at 9:40 AM, Damien Doligez wrote:

> Dear OCaml Users,
>
> We are pleased to celebrate the birthday of Friedrich Nietzsche
> by releasing OCaml version 3.11.0+beta1.  We need YOU to test
> it thoroughly and report any problems you might have.  Does
> your favorite software work with it?


Thanks for the good work. I would like to know exactly what  
architectures support the native Dynlink? I did not see this  
information in the release notes.

I need to update configure scripts to include it or not in the link  
step because dynlink.cmxa is needed by camlp4fulllib.cmxa, but now I  
realize that it's not just a matter of having OCaml >= 3.11.

many thanks again,

Andres

>
>
> It is available as a source release only (plus documentation),
> from this address:
> < http://caml.inria.fr/pub/distrib/ocaml-3.11/ >
>
> It is also available from our CVS server at:
> < http://camlcvs.inria.fr/ >
> Use tag "ocaml3110beta1" to get the beta release, and tag
> "release311" to track the bug fixes between this and the
> final release of 3.11.0.
>
> Have fun and PLEASE send us some feedback, positive or negative.
>
>
> -- The OCaml team.
>
>
> --------------------- Camlp5 HOW-TO ------------------------
>
> Camlp5 version 5.09 does not work with OCaml 3.11.0+beta1 out of the
> box.  A new version compatible with OCaml 3.11.0 should be released
> very soon.  In the meantime you can use the following commands (in the
> root directory of the Camlp5 5.09 sources) to compile Camlp5 5.09 with
> OCaml 3.11.0+beta1.  Note that you will need to provide the path name
> to a copy of the OCaml 3.11.0+beta1 sources at the line labelled
> "HERE".
>
>
> cp -R ocaml_stuff/3.11 ocaml_stuff/3.11.0
> cp ocaml_src/main/ast2pt.ml_3.11 ocaml_src/main/ast2pt.ml_3.11.0
> ed main/ast2pt.ml <<-EOF
>  g/OCAML_3_11/s//& OR OCAML_3_11_0/
>  wq
> EOF
> ed top/rprint.ml <<-EOF
>  g/OCAML_3_11/s//& OR OCAML_3_11_0/
>  wq
> EOF
> ./configure --transitional
> make steal OCAML_SRC=<path-to-ocaml-source-dir>      # HERE
> make core
> make bootstrap_sources
> ./configure --transitional
> make world.opt
>
> That's all.  Now you can "make install" as usual.
>
> _______________________________________________
> Caml-list mailing list. Subscription management:
> http://yquem.inria.fr/cgi-bin/mailman/listinfo/caml-list
> Archives: http://caml.inria.fr
> Beginner's list: http://groups.yahoo.com/group/ocaml_beginners
> Bug reports: http://caml.inria.fr/bin/caml-bugs