Version française
Home     About     Download     Resources     Contact us    
Browse thread
OCaml version 3.11.0+beta1
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Andres Varon <avaron@g...>
Subject: Re: [Caml-list] OCaml version 3.11.0+beta1

On Oct 16, 2008, at 12:22 PM, Andres Varon wrote:

>
> On Oct 16, 2008, at 5:58 AM, David Allsopp wrote:
>
>> Both the MSVC and MinGW ports seem to have an error in the Makefile -
>> they're linking against tk83.dll and tcl83.dll - the OCaml 3.10.2  
>> line to
>> link against tk84.lib and tcl84.lib is commented out.
>>
>> Changing the Makefile to link against tk84.dll and tcl84.dll seems  
>> to fix
>> the problem.
>
> Did you manage to do it with *.dll or *.lib? I don't have those  
> dll's and have been unable to compile the MinGW port with a setup  
> that succeeded since 3.09.3. I keep getting:
>
> Cannot export tcl84_NULL_THUNK_DATA: symbol not found
>
> Could it be a path issue? Could you please show me an example of the  
> a path that you are using successfully?

Let me clarify what I'm asking: I have in config/Makefile

TK_ROOT=c:/tcl

Do you write your paths somehow differently there? In all honesty I  
don't think that this is a wrongly written path (there are no  
complains of not finding the libraries), but I'm clueless and I don't  
have enough experience in Windows.

best,

Andres

>
>
>
> Andres