Version française
Home     About     Download     Resources     Contact us    
Browse thread
changing labels on ocamlgraph edges
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Matthieu Wipliez <mwipliez@y...>
Subject: Re : Re : [Caml-list] changing labels on ocamlgraph edges

> Finally, it's very annoying to see plural of vertex as also "vertex" -- in 
> G.nb_vertex or iter_vertex; it's "vertices"! :)  Also nb_ is a non-standard 
> abbreviation for "number of", perhaps better names are num_vertices and 
> num_edges?

Good point, for instance I'm using SystemC FIFOs and they have nb_read/nb_write for non-blocking read and write, and num_available/num_written for the number of tokens available and written.

Nevertheless, these are minor issues, ocamlgraph is an excellent piece of software altogether! (and a good example of why functors can be a good thing ^^).

Cheers,
Matthieu

PS : is there a list dedicated to ocamlgraph? This might be a better place for this kind of discussion :-)