Version française
Home     About     Download     Resources     Contact us    
Browse thread
Issues building batteries / installing camlzip
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Malcolm Reynolds <malcolm.reynolds@g...>
Subject: Issues building batteries / installing camlzip
Hi, apologies if this is the wrong place for this message but I'm not
sure exactly which piece of software I'm having issues with here.

I am trying to build Batteries on OS X 1.5.6. I am using a binary of
OCaml 3.11.0, and am attempting to build and install all dependencies.
My problem is that when I think I'm done, trying "./configure" in the
Batteries directory gets me this:

checking for ocamlc.opt... ocamlc.opt
checking ocaml version... configure: 3.11.0
checking for ocamlopt.opt... ocamlopt.opt
checking for ocamlbuild... ocamlbuild
checking for ocamldoc.opt... ocamldoc.opt
checking for ocamlfind... ocamlfind
checking findlib package camomile... found
checking findlib package zip... ocamlfind: Package `zip' not found
configure: WARNING: not found
checking findlib package camlzip... ocamlfind: Package `camlzip' not found
configure: WARNING: not found
configure: error: Cannot find Camlzip

Clearly some problem with camlzip, but as far as I can tell that's
installed fine. I edited the makefile variables from
/usr/local/{include,lib}/ to /usr/{include,lib} because that matches
where OS X puts those files. It seems to build with no problem, and
when I do install it looks like it's copying to `ocaml -g -where`,
which evaluates to /usr/local/lib/ocaml - there is a zip subdirectory
here, and it contains these files:

dllcamlzip.so gzip.cmx      libcamlzip.a  zip.cma       zip.cmx       zip.mli
gzip.cmi      gzip.mli      zip.a         zip.cmi       zip.cmxa

Does this look reasonable? I'm definitely still missing something,
because as well as the batteries configure script complaining, if i do
'ocamlfind list' I get a long list of libraries that does not include
zip or camlzip (all the other ones I've installed myself like
binprot/camomile/sexplib etc are present). The files are clearly being
installed somewhere, but some part of the system doesn't know where to
find them...

Does anyone have any advice on how to fix this? I wonder whether it's
due to some OS X idiosyncracy, like having library files end in
".dylib" rather that ".a"...

Thanks in advance,

Malcolm