Version française
Home     About     Download     Resources     Contact us    
Browse thread
Re: [Caml-list] Caml Light 0.8 and -fstrict-aliasing build issue
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Alexis ROBERT <alexis.robert@g...>
Subject: Re: [Caml-list] Caml Light 0.8 and -fstrict-aliasing build issue
philippe esperet a écrit :
> francois.boisson@prepas.org <mailto:francois.boisson@prepas.org>
> %%%%%%%%%%%%%%%%%%%%%
> /dosc/esperet/tex/email/@ocaml9.tex lun. juil. 20 2009 15:01:49
>
> % As the MPSI programme force us to use Caml Light instead of OCaml (our
> % teachers hit us each time we pronounce ocaml :) ), I tried to build
> % the sources on my computer, but during the build, I got this :
>
> We use Ocaml in henri IV for three years, nevertheless I try for fun
> to keep the old camllight each time I change my linux config. At home,
> on a 64 bits platform:
>
> camllight_0.80_amd64.deb from the guru François Boisson
> makes the trick with something like (suse 11.1)
>
> dpkg-deb -x camllight_0.80_amd64.deb /
At Fenelon, my teachers tell us they don't want us to have problems with 
examiners who are not familiar with OCaml, but we can use it if we want, 
even if everything is under Caml Light there.

Thanks for the trick, I was used to manually uncompress it with ar x and 
then untar data.tar.gz in / :)

I've looked into the strings of the binaries bundled in the package and 
it shows "GCC: (GNU) 3.4.6 (Ubuntu 3.4.6-8ubuntu2)", and 
-fstrict-aliasing seems disabled in GCC 3.4.

The strange thing is that even if gcc-3.4 is in build-dep of the 
dpkg-source package, I don't see where it uses it in debian/rules or any 
Makefile (and debuild fails at building the package, it doesn't execute 
the build step of rules for a reason I don't understand, but if I 
manually launch the step, I get the same error).

Thanks

Alexis