Version française
Home     About     Download     Resources     Contact us    
Browse thread
batteries compilation error
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Florent Monnier <fmonnier@l...>
Subject: Re: [Caml-list] batteries compilation error
> > Trying to compile batteries (version 20090405 on ocaml 3.11.1),
> > I get this error:
> >
> > + ocamlfind ocamlc -c -g -I src/syntax/pa_strings -I src -I src/core -I
> > src/main -I src/libs -I src/core/extlib_threads -I src/core/extlib -I
> > src/core/baselib -I src/core/baselib_threads -I src/libs/common -I
> > src/libs/camlzip -I src/libs/sexplib -I src/libs/findlib -I
> > src/libs/compilers -I src/libs/ocamlnet -I build/optcomp -o
> > src/syntax/pa_strings/pa_estring.cmi src/syntax/pa_strings/pa_estring.mli
> > File "src/syntax/pa_strings/pa_estring.mli", line 12, characters 0-19:
> > Error: Unbound module Camlp4.PreCast
> >
> > this line 12 is only:
> > open Camlp4.PreCast
> >
> >
> > Does someone have an idea of what could cause this error ?
>
> I don't see any "-I +camlp4" can you add it?

if I run the command like this on the command line it passes right
but when I run again the make command it doesn't continue because
ocamlbuild complains about sanity violation
Anyway as it is for packaging purpose I will need to patch the Makefile,
the problem is that I don't see where to add this statement in the Makefile:
http://git.ocamlcore.org/cgi-bin/gitweb.cgi?p=batteries/batteries.git;a=blob;f=Makefile.in;hb=HEAD

(also I've search in the debian package, and it seems they haven't patch the 
Makefile at all)