Version française
Home     About     Download     Resources     Contact us    
Browse thread
Re: Re: automake and ocaml
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Sylvain Le Gall <sylvain@l...>
Subject: Re: automake and ocaml
Hello,

On 22-09-2009, Daniel Molina <lalluviamola@gmail.com> wrote:
> Thanks for the reply!
>
> I have been trying to compile the ocaml-autobuild but it seem that it do
> not works.
>
> I have done make/(make test) after/before apply the patch and I obtain
> the following error:
>         
> $ make test
> ocamlbuild -classic-display ocaml-autobuild.otarget
> /usr/bin/ocamlopt -I /usr/lib/ocaml/3.10.0/ocamlbuild
> unix.cmxa /usr/lib/ocaml/3.10.0/ocamlbuild/ocamlbuildlib.cmxa
> myocamlbuild.ml /usr/lib/ocaml/3.10.0/ocamlbuild/ocamlbuild.cmx -o
> myocamlbuild
> ocamlfind ocamldep -modules src/tools/ocamlmod.ml >
> src/tools/ocamlmod.ml.depends
> ocamlfind ocamlc -c -I src/tools -I src -I src/ocamlbuild -I
> src/ocamlmakefile -I src/omake -I src/oasis -I src/base -o
> src/tools/ocamlmod.cmo src/tools/ocamlmod.ml
> ocamlfind ocamlc -linkpkg src/tools/ocamlmod.cmo -o
> src/tools/ocamlmod.byte
> src/tools/ocamlmod.byte src/base/BaseSys.mod
> ocamlfind ocamldep -package findlib -pp '-package findlib' -modules
> src/base/BaseSys.ml > src/base/BaseSys.ml.depends
> + ocamlfind ocamldep -package findlib -pp '-package findlib' -modules
> src/base/BaseSys.ml > src/base/BaseSys.ml.depends
> sh: Illegal option -p
> Preprocessing error on file src/base/BaseSys.ml
> Command exited with code 2.
> make: *** [all] Error 10
>
> Can some one help me?
>
> I downloaded the tree with 'wget -r' which did not did this very smooth.
> I have uploaded a tar version  of it (without to apply the patch).
>
> https://doppelgaenger.ath.cx/~daniel/ocaml-autobuild.tar
>

I download and build it (from your website) and I have no problem to
compile: 

gildor@yotta(lenny/amd64):~/tmp/ocaml-autobuild$ make
ocamlbuild -classic-display ocaml-autobuild.otarget
/usr/bin/ocamlopt.opt -I /usr/lib/ocaml/3.10.2/ocamlbuild unix.cmxa
/usr/lib/ocaml/3.10.2/ocamlbuild/ocamlbuildlib.cmxa myocamlbuild.ml
/usr/lib/ocaml/3.10.2/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
[...]
 src/tools/ocamlmod.byte src/base/BaseSys.mod
 ocamlfind ocamldep -package fileutils -package findlib -modules
 src/base/BaseSys.ml > src/base/BaseSys.ml.depends
 src/tools/ocamlmod.byte src/ocamlbuild/OCamlbuildSys.mod
 ocamlfind ocamldep -package fileutils -modules
 src/ocamlbuild/OCamlbuildSys.ml >
 src/ocamlbuild/OCamlbuildSys.ml.depends
 ocamlfind ocamldep -package fileutils -package findlib -modules
 src/base/BaseEnvironment.ml > src/base/BaseEnvironment.ml.depends
 ocamlfind ocamldep -package fileutils -package findlib -modules
 src/base/BaseMessage.ml > src/base/BaseMessage.ml.depends
 ocamlfind ocamlc -c -package fileutils -package findlib -I src/base -I
 src -I src/omake -I src/ocamlbuild -I src/oasis -I src/ocamlmakefile -o
  src/base/BaseMessage.cmo src/base/BaseMessage.ml
  ocamlfind ocamldep -package fileutils -package findlib -modules
  src/base/BaseExec.ml > src/base/BaseExec.ml.depends
[...]
(test not ok because it try to install things in /usr/lib/ocaml...)

Can you check you have build and install ocamlify 
http://darcs.ocamlcore.org/cgi-bin/darcsweb.cgi?r=ocamlify;a=summary
(I will try to get rid of this small dependency in the final release)

Also OCaml 3.10.0 is a quite old version that is maybe still containing
some bugs with ocamlbuild (it was the first version of ocamlbuild). Can
you try with a more recent version (3.10.2 or 3.11.1).

You can get the tree with 
darcs get http://darcs.ocamlcore.org/repos/ocamlify
darcs get http://darcs.ocamlcore.org/repos/ocaml-autobuild

Regards,
Sylvain Le Gall