Version française
Home     About     Download     Resources     Contact us    
Browse thread
Core 0.6.0
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Ralph Douglass <rdouglass@j...>
Subject: Core 0.6.0
We are proud to announce the second major release of Core, Jane Street's
alternative to OCaml's standard library.  This release also includes
Core_extended, which adds new functionality such as subcommand style command
line argument handling, a procfs interface, readline support, and more.
Core_extended is used heavily at Jane Street, but not systematically code
reviewed in the same manner as Core.

As was warned in the first release, the interfaces to many modules have changed,
so upgrade with care.  Interfaces will continue to change with future releases.

Core is intended to be used with OCaml 3.11.1.  It will not compile with 3.10.

We have tested the code on Linux (Centos 5), but have only limited experience
with it on other platforms.  It compiles on Mac OS 10.6, but has had almost no
testing on that platform, and hasn't been tested at all on anything else.

You can find the library here:

  http://www.janestreet.com/ocaml

along with three other libraries that you will need to use along with it:
type-conv, sexplib, bin-prot, and fieldslib.  These four libraries provide
macros for generating functions for serializing and deserializing types, and
for folding over records.

In addition, Core depends on Pcre and Res.  Core_extended also depends on Pcre.
You can find them at Markus's website:

  http://www.ocaml.info/home/ocaml_sources.html

If you have any comments or patches, we'd love to hear about it.  Our
blog is a great place for comments:

  http://ocaml.janestreet.com/?q=node/70

and patches should be sent to opensource@janestcapital.com.

All of the released libraries are licensed under the
LGPL-plus-linking-exception that is used by the OCaml standard
library.

- Ralph