Version française
Home     About     Download     Resources     Contact us    
Browse thread
Compatibility 3.11.1 and 3.09.3
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: michel levy <michel.levy@i...>
Subject: Compatibility 3.11.1 and 3.09.3
I have byte-code produced by ocamlc  version 3.11.1 which does not work
with ocamlrun version 3.09.3.
Is this situation normal ?
Must I have exactly the same version for the compiler producing the
byte-code and the ocamlrun
executing this code ?

    Sincerely yours.

PS : this problem occurs to me because I compile on my machine (ocaml
3.11.1) and I send the byte code
to a web server with an other version (ocaml 3.09.3) and I am not in
charge of this server.

-- 
Michel Levy
LIG, ENSIMAG D105, 681 rue de la passerelle, Domaine Universitaire,
BP72-38402 Saint Martin d'Hères Cedex
Tel:(33)476827246   e.mail : Michel.Levy@imag.fr   
http://membres-liglab.imag.fr/michel.levy