Version française
Home     About     Download     Resources     Contact us    
Browse thread
Error linking with library: Ancient.
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Hugo Ferreira <hmf@i...>
Subject: Re: [Caml-list] Re: Error linking with library: Ancient.
Hi Michael,

Michael Ekstrand wrote:
> On 03/16/2010 02:12 PM, Hugo Ferreira wrote:
>> I am using ocamlbuild to compile and link the Ancient module.
>> I have a link error. I have tried to change the command line directly
>> with no success. I have used the exact same options for the GMP and CuDD
>> libraries and don't understand why it shouldn't work with Ancient also.
>>
>> Can anyone give me a hint?
> 
> Based on the error message and your previous post, it looks to me like
> this is caused by trying to build Ancient 0.8 against OCaml 3.11; I
> believe you need Ancient 0.9[1].  In 3.11, OCaml changed some of its
> heap management data structures.
> 

I did not see any mention of this in the readme.
However the ancient_c.c file of version 0.8 in fact
does not have any conditional compilation for 3.11
as does version 0.9.

Haven't tried yet, but looks like you are correct.

Thank you,
Hugo F.


> - Michael
> 
> 1. http://merjis.com/developers/ancient
> 
> _______________________________________________
> Caml-list mailing list. Subscription management:
> http://yquem.inria.fr/cgi-bin/mailman/listinfo/caml-list
> Archives: http://caml.inria.fr
> Beginner's list: http://groups.yahoo.com/group/ocaml_beginners
> Bug reports: http://caml.inria.fr/bin/caml-bugs
>