Version française
Home     About     Download     Resources     Contact us    
Browse thread
Inspect libary
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Ashish Agarwal <agarwal1975@g...>
Subject: Re: [Caml-list] Inspect libary
Regarding LGPL 2.1 versus 3.0, I recently tried finding the linking
exception for 3.0 but concluded that no one has written it yet (from
postings to the OCaml list, beginners list, and contacting the FSF). So if
you're going to include the linking exception, which most LGPL'd ocaml
libraries do, and you don't want to write the linking exception yourself,
then your only choice is 2.1.


On Thu, Apr 15, 2010 at 6:42 AM, Kaspar Rohrer <kaspar.rohrer@gmail.com>wrote:

> Hi everybody
>
> Thanks for all the feedback and suggestions regarding hosting and licensing
> of my little library. I think I will host the code on github, because I
> really like the clean and shiny UI.
> As for the license, I'm strongly favoring the LGPL license ATM, but I am
> unsure whether I should go with version 2.1 or 3.0. And whether or not I
> need to add a linking exception. Any opinions on that?
>
> I'm currently documenting the source code and should be ready to release
> this evening.
>
> Thanks
>         Kaspar Rohrer
>
> PS: Does somebody know why all of my browsers (Firefox, Safari, Camino on
> OS X 10.6) do not recognize the Forge.ocamlcore.org server certificate?
>
> _______________________________________________
> Caml-list mailing list. Subscription management:
> http://yquem.inria.fr/cgi-bin/mailman/listinfo/caml-list
> Archives: http://caml.inria.fr
> Beginner's list: http://groups.yahoo.com/group/ocaml_beginners
> Bug reports: http://caml.inria.fr/bin/caml-bugs
>