Version française
Home     About     Download     Resources     Contact us    
Browse thread
ocamlbuild: full path for camlp4 preprocessors?
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Hendrik Tews <tews@o...>
Subject: ocamlbuild: full path for camlp4 preprocessors?
Hi,

I have another ocamlbuild question: How can I tell ocamlbuild to
use the full path for the camlp4 preprocessors?

I just compiled ocaml 3.12 to test if it compiles my software. So
I do

   /soft/ocaml-3.12.0/bin/ocamlbuild target.native

and ocamlbuild is clever enough to prefix all commands with
/soft/ocaml-3.12.0/bin to make sure the 3.12 compiler
is used. But then comes this file that needs camlp4 and
ocamlbuild runs

   /soft/ocaml-3.12.0/bin/ocamldep.opt -pp camlp4orf -modules xx.ml > ...

which of course fails because camlp4orf is version 3.11.2 from
/usr/bin.

How can I tell ocamlbuild to also use the full path for camlp4
preprocessors?

(I could put /soft/ocaml-3.12.0/bin into PATH, but there should
be a way to solve this problem without changing PATH: It should
be possible to run ocamlbuild without putting the ocaml-bin-dir
into PATH)

Thanks,

Hendrik Tews