MantisBT - OCaml
View Issue Details
0000317OCaml~DO NOT USE (was: OCaml general)public2001-03-20 17:222001-03-29 15:17
administrator 
 
normalminoralways
closedno change required 
 
 
0000317: Compile-problem: no file "boot/ocamlrun"
Hello,

I tried to install ocaml-3.01 on an old Suse-Linux
(SUSE 4.3).

No problems during configure.
Problems while running make: The file "boot/ocamlrun" was not found.

Is there a fix for that problem?



Another problem: On this system is no pthreads-library installed,
but the configure-summary tells, that threads-libs are supported.
I hope that is no problem, here (in the compiling-options the
pthread-libs are not).

Regards,
     Oliver Bandel

No tags attached.
Issue History
2005-11-18 10:13administratorNew Issue
2017-02-23 16:36doligezCategoryOCaml general => -OCaml general
2017-03-03 17:55doligezCategory-OCaml general => -(deprecated) general
2017-03-03 18:01doligezCategory-(deprecated) general => ~deprecated (was: OCaml general)
2017-03-06 17:04doligezCategory~deprecated (was: OCaml general) => ~DO NOT USE (was: OCaml general)

Notes
(0002237)
administrator   
2001-03-26 15:22   
> Hello,
>
> I tried to install ocaml-3.01 on an old Suse-Linux
> (SUSE 4.3).
>
> No problems during configure.
> Problems while running make: The file "boot/ocamlrun" was not found.
> Is there a fix for that problem?

Can't say with so little info. Is there a file boot/ocamlrun?
You can also set the OCAMLRUNPARAM environment variable to "v=511"
before doing "make world" and you should get more messages from the
system.

> Another problem: On this system is no pthreads-library installed,
> but the configure-summary tells, that threads-libs are supported.
> I hope that is no problem, here (in the compiling-options the
> pthread-libs are not).

Should be OK. By default, OCaml configures its own thread library
that does not rely on the POSIX pthread library.

Best regards,

- Xavier Leroy

(0002238)
administrator   
2001-03-26 21:59   
Hello!


On Mon, 26 Mar 2001, Xavier Leroy wrote:

> > Hello,
> >
> > I tried to install ocaml-3.01 on an old Suse-Linux
> > (SUSE 4.3).
> >
> > No problems during configure.
> > Problems while running make: The file "boot/ocamlrun" was not found.
> > Is there a fix for that problem?
>
> Can't say with so little info. Is there a file boot/ocamlrun?

No.

> You can also set the OCAMLRUNPARAM environment variable to "v=511"
> before doing "make world" and you should get more messages from the
> system.

Hmhhh. i may have downloaded the wrong distribution.
It's not very hughlited, which version can be used
even without a previous OCAML.
So I may have downloaded the version, which needs a running
ocaml.


>
> > Another problem: On this system is no pthreads-library installed,
> > but the configure-summary tells, that threads-libs are supported.
> > I hope that is no problem, here (in the compiling-options the
> > pthread-libs are not).
>
> Should be OK. By default, OCaml configures its own thread library
> that does not rely on the POSIX pthread library.

Oh, really? That's cool.
Does it work with an old 2.0.18-Linux kernel?


Regards,
    Oliver Bandel

--
Remember, Information is not knowledge; Knowledge is not Wisdom;
Wisdom is not truth; Truth is not beauty; Beauty is not love;
Love is not music; Music is the best.
                                      (Frank Zappa)

(0002239)
administrator   
2001-03-27 05:12   
> I tried to install ocaml-3.01 on an old Suse-Linux
> (SUSE 4.3).
>
> No problems during configure.
> Problems while running make: The file "boot/ocamlrun" was not found.
>
> Is there a fix for that problem?

Be sure to do "make world" and not simply "make".
The compiler needs some boostraping code which is installed in boot only by
"make world".

    Jacques Garrigue
(0002240)
administrator   
2001-03-29 15:17   
User not following installation instructions.