Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003829OCamltypingpublic2005-11-03 15:492017-05-09 16:33
Reporterfrisch 
Assigned Toshinwell 
PrioritynormalSeveritytweakReproducibilityalways
StatusconfirmedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0003829: Nom de module = nom d'exception
DescriptionSuite à une inspection du code et une discussion avec Xavier...

buzet ~/bug $ cat not_found.ml
let rec f x = 10
buzet ~/bug $ cat a.ml
Not_found.f 5;;
buzet ~/bug $ ocamlopt -c not_found.ml
buzet ~/bug $ ocamlopt -c a.ml
buzet ~/bug $ ocamlopt -o foo a.cmx
a.o: In function `camlA__entry':
: undefined reference to `camlNot_found__f_57'
collect2: ld returned 1 exit status
Error during linking

alors qu'on s'attendrait à un message du genre:

No implementations provided for the following modules:
   Not_found referenced from a.cmx


Ça se produit dès que le nom de l'unité est un des noms d'exception
prédéfinis.

-- Alain

TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0017315)
doligez (administrator)
2017-02-17 16:37

still present in 4.05
(0017789)
shinwell (developer)
2017-05-09 16:15

I cannot reproduce this in trunk (rev b0f6e32eb).
(0017791)
frisch (developer)
2017-05-09 16:33

Problem still present, with a slightly modified example in not_found.ml:

let rec f x = print_int x; f x


- Issue History
Date Modified Username Field Change
2005-11-18 10:14 administrator New Issue
2012-07-11 16:48 doligez Target Version => 4.01.0+dev
2012-07-11 16:48 doligez Description Updated View Revisions
2012-07-31 13:37 doligez Target Version 4.01.0+dev => 4.00.1+dev
2012-09-11 13:54 doligez Target Version 4.00.1+dev => 4.00.2+dev
2013-06-14 14:37 frisch Severity minor => tweak
2013-06-14 14:37 frisch Target Version 4.00.2+dev => 4.02.0+dev
2013-07-12 18:15 doligez Target Version 4.02.0+dev => 4.01.1+dev
2014-05-25 20:20 doligez Target Version 4.01.1+dev => 4.02.0+dev
2014-07-16 21:00 doligez Target Version 4.02.0+dev => 4.02.1+dev
2014-09-04 00:25 doligez Target Version 4.02.1+dev => undecided
2014-09-23 17:23 doligez Target Version undecided => 4.03.0+dev / +beta1
2016-04-14 17:33 doligez Target Version 4.03.0+dev / +beta1 => 4.03.1+dev
2017-02-16 14:01 doligez Target Version 4.03.1+dev => undecided
2017-02-17 16:37 doligez Note Added: 0017315
2017-02-17 16:37 doligez Target Version undecided => 4.06.0 +dev/beta1/beta2/rc1
2017-02-23 16:36 doligez Category OCaml general => -OCaml general
2017-02-27 15:17 doligez Reporter administrator => frisch
2017-02-27 15:17 doligez Category -OCaml general => typing
2017-02-27 15:17 doligez Target Version 4.06.0 +dev/beta1/beta2/rc1 =>
2017-05-09 16:15 shinwell Note Added: 0017789
2017-05-09 16:15 shinwell Status acknowledged => resolved
2017-05-09 16:15 shinwell Resolution open => fixed
2017-05-09 16:15 shinwell Assigned To => shinwell
2017-05-09 16:33 frisch Note Added: 0017791
2017-05-09 16:33 frisch Status resolved => confirmed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker