Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003966OCaml~DO NOT USE (was: OCaml general)public2006-01-28 15:202012-09-25 20:10
Reporteranonymous 
Assigned Tofrisch 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionunable to reproduce 
PlatformOSOS Version
Product Version3.08.3 
Target VersionFixed in Version 
Summary0003966: Crash will varying placement of Callback.register
DescriptionHullo.

I call caml_main immediately followed by callback from a program written in C++.

It works if the callback is registered prior to the last function evaluated in initialisation:

let register = Callback.register "Get canvas" canvas

let _ = (* rest of program initialisation *)

But if the Callback.register is in the final let _ ...

let _ = Callback.register "Get canvas" canvas

... it crashes with SIGILL. I can't see anything in the documentation warning about this placement of Callback.register.

I'm compiling on PowerPC.

Cheers,

John Whitington
jgw25@cam.ac.uk
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0007829)
frisch (developer)
2012-07-29 17:56

Maybe the "rest of program initialisation" calls into C++, which assumes "Get canvas" is already registered?

This is a very old ticket, with no reproduction case. I'm marking it as "resolved / unable to reproduce".

- Issue History
Date Modified Username Field Change
2006-01-28 15:20 anonymous New Issue
2006-03-29 16:29 doligez Status new => acknowledged
2012-07-11 16:45 doligez Target Version => 4.01.0+dev
2012-07-29 17:56 frisch Note Added: 0007829
2012-07-29 17:56 frisch Status acknowledged => resolved
2012-07-29 17:56 frisch Resolution open => unable to reproduce
2012-07-29 17:56 frisch Assigned To => frisch
2012-07-29 17:56 frisch Target Version 4.01.0+dev =>
2012-09-25 20:10 xleroy Status resolved => closed
2017-02-23 16:36 doligez Category OCaml general => -OCaml general
2017-03-03 17:55 doligez Category -OCaml general => -(deprecated) general
2017-03-03 18:01 doligez Category -(deprecated) general => ~deprecated (was: OCaml general)
2017-03-06 17:04 doligez Category ~deprecated (was: OCaml general) => ~DO NOT USE (was: OCaml general)


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker