Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004056OCaml-OCaml generalpublic2006-06-29 01:152016-12-12 16:55
Reportermottl 
Assigned To 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionwon't fix 
PlatformOSOS Version
Product Version3.09.3 
Target VersionFixed in Version 
Summary0004056: Bad compressibility of marshalled OCaml-data
DescriptionI have just finished (and attached) a patch for the latest CVS-release
of OCaml, which adds a new marshalling flag. This flag generates a
different marshalling format, which uses absolute addresses to refer
to shared values. This fixes the problem of bad compressibility of
marshalled OCaml data. See the patch header for more information.

Since the patch is quite small and does not break any existing code,
we'd be very grateful if it could be made part of the next
OCaml-release. Thanks!
Tagspatch
Attached Filespatch file icon absolute.patch [^] (10,694 bytes) 2006-06-29 01:15 [Show Content]

- Relationships

-  Notes
(0004493)
mottl (reporter)
2008-04-14 21:06

A quick update to this issue: the patch for "absolute sharing" contains a copyright notice for Jane Street Holding, LLC. As far as I know INRIA has a policy that copyright must be transferable to INRIA, otherwise code cannot be integrated into official distributions.

Since this patch would otherwise be of rather limited use to INRIA and hence other OCaml-users, including us, we (Jane Street Holding, LLC) herewith grant INRIA the right to redistribute or use any code contained in the above file "absolute.patch" in any form without any restrictions, with our without any reference to our authorship. We, Jane Street Holding, LLC, disclaim any and all responsibility or liability arising from the use of this patch and its contained code as stated in the original patch.

I hope this will make it easier for you to accept this patch. The implemented feature would be very helpful for many users who have to store large amounts of marshaled data. The only way around this problem right now is to essentially maintain a patched copy of the affected runtime files, which is quite inconvenient. The proposed patch is very simple and should not break existing code. It would be great if it could be added in an upcoming release. Thanks!
(0016971)
shinwell (developer)
2016-12-12 16:54
edited on: 2016-12-12 16:55

This patch from the depths (almost the dawn) of time I think no longer has the support of its (corporate) author, so let's close this issue.


- Issue History
Date Modified Username Field Change
2006-06-29 01:15 mottl New Issue
2006-06-29 01:15 mottl File Added: absolute.patch
2006-08-29 17:07 doligez Status new => acknowledged
2008-04-14 21:06 mottl Note Added: 0004493
2013-09-03 17:12 doligez Tag Attached: patch
2016-12-12 16:54 shinwell Note Added: 0016971
2016-12-12 16:54 shinwell Status acknowledged => closed
2016-12-12 16:54 shinwell Resolution open => won't fix
2016-12-12 16:55 shinwell Assigned To => shinwell
2016-12-12 16:55 shinwell Status closed => feedback
2016-12-12 16:55 shinwell Resolution won't fix => reopened
2016-12-12 16:55 shinwell Note Edited: 0016971 View Revisions
2016-12-12 16:55 shinwell Status feedback => closed
2016-12-12 16:55 shinwell Assigned To shinwell =>
2016-12-12 16:55 shinwell Resolution reopened => won't fix
2017-02-23 16:36 doligez Category OCaml general => -OCaml general


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker