Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004778OCaml~DO NOT USE (was: OCaml general)public2009-04-28 13:242012-09-25 20:06
Reporterdb 
Assigned Toxleroy 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.11.0 
Target VersionFixed in Version 
Summary0004778: Ocamlopt generates an incorrect .asm
DescriptionYour own CVS test/Moretest/recmod.ml fails under Win32/MSVC ocamlopt:

ocamlopt -c -S recmod.ml
File "recmod.ml", line 1, characters 0-1:
Error: Assembler error, input left in file recmod.asm

The problem is here: recmod.ml, line 293

L100192 .DATA
    DWORD 0
TagsNo tags attached.
Attached Files

- Relationships
related to 0005391closedxleroy Erroneous assembly when using recursive modules on Windows/MSVC 

-  Notes
(0005975)
xleroy (administrator)
2011-06-04 17:23

Tentative fix in 3.12 bugfix branch, scheduled for inclusion in 3.12.1.
Not tested yet, but same workaround used in Win64/MSVC port.

- Issue History
Date Modified Username Field Change
2009-04-28 13:24 db New Issue
2009-04-29 16:00 doligez Status new => assigned
2009-04-29 16:00 doligez Assigned To => xleroy
2011-06-04 17:23 xleroy Note Added: 0005975
2011-06-04 17:23 xleroy Status assigned => resolved
2011-06-04 17:23 xleroy Resolution open => fixed
2011-11-21 13:21 xleroy Relationship added related to 0005391
2012-09-25 20:06 xleroy Status resolved => closed
2017-02-23 16:36 doligez Category OCaml general => -OCaml general
2017-03-03 17:55 doligez Category -OCaml general => -(deprecated) general
2017-03-03 18:01 doligez Category -(deprecated) general => ~deprecated (was: OCaml general)
2017-03-06 17:04 doligez Category ~deprecated (was: OCaml general) => ~DO NOT USE (was: OCaml general)


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker