Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005526OCaml~DO NOT USE (was: OCaml general)public2012-03-07 12:002013-08-31 12:48
Reporterfrisch 
Assigned Tofrisch 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0005526: Warning 31 (linking twice the same module name) cannot be made fatal
DescriptionThe new warning 31 is never turned into an error, even with -warn-error +31.

This is because Warnings.check_fatal is only called after compilation, not linking.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0007020)
frisch (developer)
2012-03-07 12:08

Commit 12196. I've added calls to check_fatal after all linking operations in main.ml and optmain.ml (even though some of these operations can currently raise warnings, but this could change later).

- Issue History
Date Modified Username Field Change
2012-03-07 12:00 frisch New Issue
2012-03-07 12:05 frisch Assigned To => frisch
2012-03-07 12:05 frisch Status new => assigned
2012-03-07 12:08 frisch Note Added: 0007020
2012-03-07 12:08 frisch Status assigned => resolved
2012-03-07 12:08 frisch Resolution open => fixed
2013-08-31 12:48 xleroy Status resolved => closed
2017-02-23 16:36 doligez Category OCaml general => -OCaml general
2017-03-03 17:55 doligez Category -OCaml general => -(deprecated) general
2017-03-03 18:01 doligez Category -(deprecated) general => ~deprecated (was: OCaml general)
2017-03-06 17:04 doligez Category ~deprecated (was: OCaml general) => ~DO NOT USE (was: OCaml general)


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker