Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005940OCaml~DO NOT USE (was: OCaml general)public2013-03-07 01:202015-12-11 19:18
Reporterhongboz 
Assigned Tohongboz 
PrioritynormalSeverityfeatureReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0005940: Clean up the compiler library interface
DescriptionI just take a look at how Fan depends on the compiler library today, and find that the dependency is quite minimal, but with a bit clean up in the compiler library, maybe it could remove the dependency on the compiler library.

Dependency on the compiler related:

Config.ast_intf_magic_number
Config.ast_intf_magic_number
(* suggestions: move them to Sys library*)

parsetree.mli
location.mli
longident.mli

(* suggestion:
   location.ml and longident.ml may be could be removed following the same convention as parseetree.mli
   and then distributed with the standard library
*)


typedtree.mli
types.mli
cmi_format.ml
(*
  These are advanced features provided by Fan, so maybe it is acceptable to linking with the compiler
*)
Thanks
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0009360)
hongboz (developer)
2013-05-28 03:50
edited on: 2013-05-28 03:54

I plan to change function print_config in utils/config.mlp and config.mlbuild to print the magic number so that we could get rid of the linking dependency on compiler-libs for Fan.
Since the change is modest, if nobody opposes, I would do it later

(0009367)
hongboz (developer)
2013-05-29 01:54

fixed in revision 13709

- Issue History
Date Modified Username Field Change
2013-03-07 01:20 hongboz New Issue
2013-05-28 03:50 hongboz Note Added: 0009360
2013-05-28 03:51 hongboz Assigned To => hongboz
2013-05-28 03:51 hongboz Status new => acknowledged
2013-05-28 03:53 hongboz Note Edited: 0009360 View Revisions
2013-05-28 03:54 hongboz Note Edited: 0009360 View Revisions
2013-05-29 01:54 hongboz Note Added: 0009367
2013-05-29 01:55 hongboz Status acknowledged => resolved
2013-05-29 01:55 hongboz Resolution open => fixed
2015-12-11 19:18 xleroy Status resolved => closed
2017-02-23 16:36 doligez Category OCaml general => -OCaml general
2017-03-03 17:55 doligez Category -OCaml general => -(deprecated) general
2017-03-03 18:01 doligez Category -(deprecated) general => ~deprecated (was: OCaml general)
2017-03-06 17:04 doligez Category ~deprecated (was: OCaml general) => ~DO NOT USE (was: OCaml general)


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker