Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006397OCaml~DO NOT USE (was: OCaml general)public2014-05-06 19:192015-12-11 19:26
Reportergmelquiond 
Assigned Tolpw25 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version4.02.0+dev 
Summary0006397: Token += can no longer be used in expression
DescriptionWith the trunk version, the following code no longer compiles.

let (+=) a b = ()
let f a b = a += b

I understand that token += is now used for open types, but I am not sure if the syntax change for expressions is intended or just an oversight. If the former, I suggest to document it (sorry if it is and I missed it). This issue was reported to us since it breaks the compilation of Why3 for some users.
TagsNo tags attached.
Attached Filespatch file icon plus-eq.patch [^] (369 bytes) 2014-05-06 20:08 [Show Content]

- Relationships

-  Notes
(0011365)
lpw25 (developer)
2014-05-06 20:08

Oops, I missed a case in the parser. The attached patch fixes it. Could someone merge this and mark as resolved?
(0011370)
gasche (developer)
2014-05-06 21:58

Merged, thanks for the report and the fix reactivity!

- Issue History
Date Modified Username Field Change
2014-05-06 19:19 gmelquiond New Issue
2014-05-06 20:08 lpw25 Note Added: 0011365
2014-05-06 20:08 lpw25 File Added: plus-eq.patch
2014-05-06 21:58 gasche Note Added: 0011370
2014-05-06 21:58 gasche Status new => resolved
2014-05-06 21:58 gasche Fixed in Version => 4.02.0+dev
2014-05-06 21:58 gasche Resolution open => fixed
2014-05-06 21:58 gasche Assigned To => lpw25
2015-12-11 19:26 xleroy Status resolved => closed
2017-02-23 16:36 doligez Category OCaml general => -OCaml general
2017-03-03 17:55 doligez Category -OCaml general => -(deprecated) general
2017-03-03 18:01 doligez Category -(deprecated) general => ~deprecated (was: OCaml general)
2017-03-06 17:04 doligez Category ~deprecated (was: OCaml general) => ~DO NOT USE (was: OCaml general)


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker