Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006502OCaml-for ocamlbuild use https://github.com/ocaml/ocamlbuild/issuespublic2014-07-29 14:562016-12-07 11:34
Reporterxleroy 
Assigned Togasche 
PrioritynormalSeveritytweakReproducibilityalways
StatusclosedResolutionfixed 
PlatformARMOSLinuxOS Version
Product Version4.02.0+dev 
Target Version4.02.1+devFixed in Version 
Summary0006502: spurious warning on "use_menhir" tag
DescriptionHaving "true: use_menhir" in _tags, I get the following warning:

Warning: the tag "use_menhir" is not used in any flag declaration, so it will have no effect; it may be a typo. Otherwise use `mark_tag_used` in your myocamlbuild.ml to disable this warning.

I believe this warning is spurious, since "use_menhir" does take effect.

Suggested fix, to be confirmed by ocamlbuild experts: in ocamlbuild/main.ml, add "use_menhir" to the list "builtin_useful_tags" on line 61.

TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0011977)
gasche (developer)
2014-08-06 13:17

Fixed as suggested.

- Issue History
Date Modified Username Field Change
2014-07-29 14:56 xleroy New Issue
2014-07-30 21:01 doligez Status new => confirmed
2014-07-30 21:01 doligez Target Version => 4.02.1+dev
2014-08-05 17:15 gasche Assigned To => gasche
2014-08-05 17:15 gasche Status confirmed => assigned
2014-08-06 13:17 gasche Note Added: 0011977
2014-08-06 13:17 gasche Status assigned => resolved
2014-08-06 13:17 gasche Resolution open => fixed
2016-12-07 11:34 xleroy Status resolved => closed
2017-02-23 16:34 doligez Category OCamlbuild (the tool) => for ocamlbuild use https://github.com/ocaml/ocamlbuild/issues [^]
2017-02-23 16:44 doligez Category for ocamlbuild use https://github.com/ocaml/ocamlbuild/issues [^] => -for ocamlbuild use https://github.com/ocaml/ocamlbuild/issues [^]


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker