Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006702OCaml-for ocamlbuild use https://github.com/ocaml/ocamlbuild/issuespublic2014-12-10 14:332016-12-07 11:37
Reporterwhitequark 
Assigned Togasche 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version4.03.0+dev / +beta1 
Summary0006702: Expose more ocamlfind options as tags
DescriptionSpecifically I need this for a peculiar toplevel extension:

    ocamlc -a -linkpkg -dontlink compiler-libs.common ...

linkpkg and dontlink(...) could be exported as flags:

    flag ["ocaml"; "link"; "linkpkg"] & A"-linkpkg";
    pflag ["ocaml"; "link"] "dontlink" (fun pkg -> S[A"-dontlink"; A pkg]);
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0012789)
gasche (administrator)
2014-12-13 14:18

If I'm not mistaken, -linkpkg and -dontlink are ocamlfind options, not ocamlc options. -linkpkg is added automatically at link-time when -use-ocamlfind is passed, so your first "flag" comment seems subsumed by what's already there:

  https://github.com/ocaml/ocaml/blob/trunk/ocamlbuild/ocaml_specific.ml#L559-L561 [^]

The -dontlink pflag looks like an excellent idea.

Could you confirm that the -linkpkg one is unnecessary, or explain why you need it?
(0012790)
whitequark (developer)
2014-12-13 16:28

What I wanted is to make a cma that includes cmas from other packages. Passing linkpkg to ocamlc -a explicitly does exactly this.

I have since used a different implementation, however it might still be useful.
(0012812)
gasche (administrator)
2014-12-14 21:58

Implemented in trunk.

- Issue History
Date Modified Username Field Change
2014-12-10 14:33 whitequark New Issue
2014-12-10 14:33 whitequark Description Updated View Revisions
2014-12-13 14:18 gasche Note Added: 0012789
2014-12-13 16:28 whitequark Note Added: 0012790
2014-12-14 21:58 gasche Note Added: 0012812
2014-12-14 21:58 gasche Status new => resolved
2014-12-14 21:58 gasche Fixed in Version => 4.03.0+dev / +beta1
2014-12-14 21:58 gasche Resolution open => fixed
2014-12-14 21:58 gasche Assigned To => gasche
2016-12-07 11:37 xleroy Status resolved => closed
2017-02-23 16:34 doligez Category OCamlbuild (the tool) => for ocamlbuild use https://github.com/ocaml/ocamlbuild/issues [^]
2017-02-23 16:44 doligez Category for ocamlbuild use https://github.com/ocaml/ocamlbuild/issues [^] => -for ocamlbuild use https://github.com/ocaml/ocamlbuild/issues [^]


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker