Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006722OCamlback end (clambda to assembly)public2014-12-18 06:322017-02-16 15:15
ReporterKiloByte 
Assigned To 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version4.02.1 
Target Version4.03.0+dev / +beta1Fixed in Version4.03.0+dev / +beta1 
Summary0006722: support for the x32 architecture
DescriptionThis patch adds support for the x32 architecture, on Linux.

As you can see, most of the troubles came from the current code confusing x32 with amd64 and i386. It should also be possible to borrow pieces from those two architectures to add native support, however, not knowing anything about ocaml or the compiler, I went with bytecode only for now.
Tagspatch
Attached Filespatch file icon x32.patch [^] (2,985 bytes) 2014-12-18 06:32 [Show Content]

- Relationships

-  Notes
(0014255)
xleroy (administrator)
2015-07-24 14:32

Partially merged in trunk, commit 16243. I lefet out the otherlibs/num part because this library is on its way to a standalone package and its configuration will have to be revised then.

- Issue History
Date Modified Username Field Change
2014-12-18 06:32 KiloByte New Issue
2014-12-18 06:32 KiloByte File Added: x32.patch
2014-12-18 08:55 gasche Category OCaml internal build/install (Makefiles, configure) => OCaml backend (code generation)
2015-01-09 00:49 doligez Tag Attached: patch
2015-01-09 00:49 doligez Status new => acknowledged
2015-01-09 00:49 doligez Target Version => 4.02.2+dev / +rc1
2015-03-18 17:54 frisch Target Version 4.02.2+dev / +rc1 => 4.02.3+dev
2015-07-10 17:45 doligez Target Version 4.02.3+dev => 4.03.0+dev / +beta1
2015-07-24 14:32 xleroy Note Added: 0014255
2015-07-24 14:32 xleroy Status acknowledged => resolved
2015-07-24 14:32 xleroy Resolution open => fixed
2015-07-24 14:32 xleroy Fixed in Version => 4.03.0+dev / +beta1
2017-02-16 15:15 xleroy Status resolved => closed
2017-02-23 16:35 doligez Category OCaml backend (code generation) => Back end (clambda to assembly)
2017-02-23 16:44 doligez Category Back end (clambda to assembly) => back end (clambda to assembly)


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker