Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006767OCamlocamldocpublic2015-01-30 15:082016-12-07 11:47
Reporterfrisch 
Assigned Tofrisch 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version4.03.0+dev / +beta1 
Summary0006767: Invalid_argument("index out of bounds") from ocamldoc on trunk
DescriptionAfter synchronizing with trunk, I get the following error from ocamldoc:

Fatal error: exception Invalid_argument("index out of bounds")
Raised by primitive operation at file "odoc_html.ml", line 72, characters 16-28
Called from file "odoc_html.ml", line 91, characters 27-49
Called from file "odoc_html.ml", line 2310, characters 48-58
Called from file "list.ml", line 91, characters 12-15
Called from file "list.ml", line 91, characters 12-15
Called from file "odoc_html.ml", line 2332, characters 8-32
Called from file "odoc_html.ml", line 2792, characters 8-46
Called from file "odoc.ml", line 126, characters 6-32

The argument 'name' in the Odoc_html.html_files function is equal to "Pervasives." (with the final dot character, hence the exception).

In the f_ele function (around line 2310), we have:

  name e = "Pervasives..()"
  Name.simple (name e) = "()"
  Name.father (name e) = "Pervasives."

So this seems to be related to the new support for custom index operators.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0013198)
frisch (developer)
2015-01-30 15:54

Hopefully fixed by commit 15801.

Seriously, the function Odoc_name.cut is really an example of code obfuscation and should be rewritten.

- Issue History
Date Modified Username Field Change
2015-01-30 15:08 frisch New Issue
2015-01-30 15:08 frisch Status new => assigned
2015-01-30 15:08 frisch Assigned To => guesdon
2015-01-30 15:17 frisch Description Updated View Revisions
2015-01-30 15:25 frisch Description Updated View Revisions
2015-01-30 15:46 frisch Description Updated View Revisions
2015-01-30 15:49 guesdon Assigned To guesdon => frisch
2015-01-30 15:54 frisch Note Added: 0013198
2015-03-11 16:46 frisch Status assigned => resolved
2015-03-11 16:46 frisch Fixed in Version => 4.03.0+dev / +beta1
2015-03-11 16:46 frisch Resolution open => fixed
2016-12-07 11:47 xleroy Status resolved => closed
2017-02-23 16:46 doligez Category OCamldoc => ocamldoc


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker