Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006780OCaml~DO NOT USE (was: OCaml general)public2015-02-12 08:542017-02-16 15:18
Reporterwhitequark 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformARMOSOS Version
Product Version 
Target Version4.03.0+dev / +beta1Fixed in Version4.03.0+dev / +beta1 
Summary0006780: The -ffpu ocamlopt option does not actually work
DescriptionThe following happens:

$ ~/.opam/4.02.1+32bit/arm-linux-androideabi/bin/ocamlopt -ffpu vfp3 -o power.native power.ml
/home/whitequark/.opam/4.02.1+32bit/arm-linux-androideabi/bin/ocamlopt: vfp3.
Usage: ocamlopt <options> <files>
[usage message]
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0013274)
whitequark (developer)
2015-02-12 08:56

Oh, I just realized that this is how it reports an error in case of an invalid choice. That's an astoundingly bad error "message".
(0013275)
whitequark (developer)
2015-02-12 09:10
edited on: 2015-02-12 09:10

Also, a wish: be able to set ABI (linux_eabi/linux_eabihf mainly) along with architecture and FPU type. Currently you can not switch to softfloat without recompiling the whole compiler, and vice versa.

(0013320)
doligez (administrator)
2015-02-19 20:55

We definitely need better error messages for -farch and -ffpu.

For choosing the ABI from the command line, I don't know enough about ARM to tell whether it's easy to do.
(0013321)
whitequark (developer)
2015-02-20 02:11

It does not significantly differ from choosing arch or cpu. Just needs some minor refactoring in arch.ml (I think)
(0015054)
xleroy (administrator)
2015-12-06 16:58

Error message improved, commit [trunk 9d78aa7].

Choosing the ABI on the command-line is currently impossible, because you would need different versions of the run-time system to be installed.

- Issue History
Date Modified Username Field Change
2015-02-12 08:54 whitequark New Issue
2015-02-12 08:56 whitequark Note Added: 0013274
2015-02-12 09:10 whitequark Note Added: 0013275
2015-02-12 09:10 whitequark Note Edited: 0013275 View Revisions
2015-02-19 20:55 doligez Note Added: 0013320
2015-02-19 20:55 doligez Status new => acknowledged
2015-02-19 20:55 doligez Target Version => 4.02.3+dev
2015-02-20 02:11 whitequark Note Added: 0013321
2015-07-10 17:31 doligez Target Version 4.02.3+dev => 4.03.0+dev / +beta1
2015-12-06 16:58 xleroy Note Added: 0015054
2015-12-06 16:58 xleroy Status acknowledged => resolved
2015-12-06 16:58 xleroy Resolution open => fixed
2015-12-06 16:58 xleroy Fixed in Version => 4.03.0+dev / +beta1
2017-02-16 15:18 xleroy Status resolved => closed
2017-02-23 16:36 doligez Category OCaml general => -OCaml general
2017-03-03 17:55 doligez Category -OCaml general => -(deprecated) general
2017-03-03 18:01 doligez Category -(deprecated) general => ~deprecated (was: OCaml general)
2017-03-06 17:04 doligez Category ~deprecated (was: OCaml general) => ~DO NOT USE (was: OCaml general)


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker