Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006793OCaml-for ocamlbuild use https://github.com/ocaml/ocamlbuild/issuespublic2015-02-24 17:502016-12-07 11:47
Reporterdoligez 
Assigned Togasche 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version4.02.2+dev / +rc1 
Target Version4.02.2+dev / +rc1Fixed in Version4.02.2+dev / +rc1 
Summary0006793: ocamlbuild infer tag breaks mezzo
DescriptionCommit 15698 introduced an `infer` tag for `menhir` but this breaks `mezzo`: `ocamlbuild` tries to launch the following command:
```
menhir --explain --infer -la 1 --table --ocamlc 'ocamlfind ocamlc --infer -g -annot -bin-annot -strict-sequence -package yojson -package menhirLib -package ulex -package pprint -package fix -package unix -package functory -package str -package ocamlbuild -I parsing -I utils -I lib -I interpreter -I ocamlbuild -I typing -I stdlib -I mezzolib -I compiler -I corelib -I tests/unit' --infer parsing/grammar.mly
```
and `ocamlc` gets a --infer on its command line, so it fails.
Steps To ReproduceJust install mezzo with opam.
TagsNo tags attached.
Attached Files

- Relationships
child of 0006237closedgasche optional "--infer" in menhir command line 

-  Notes
(0013341)
doligez (administrator)
2015-02-25 00:03

I just noticed that the original PR for this change was 0006237.
(0013624)
doligez (administrator)
2015-04-01 16:59

Note: this problem appears in 4.02, although 0006237 claims the patch was only in trunk.
(0013665)
gasche (administrator)
2015-04-11 19:33

The "infer" tag is only a symptom: this breakage is caused by the fact that ocamlbuild passes menhir an "-ocamlc ..." command that uses all the tags of the current .mly files, rather than tags appropriate to compile ocaml files.
(0013666)
gasche (administrator)
2015-04-11 19:42

This should be fixed (in trunk and 4.02). I decided to try to apply a clean fix to 4.02 instead of just reverting the breakage-provoking commit, but we may revert that decision if it turns out the patch has unintended consequences (in any case it only changes the behaviour of ocamlbuild on menhir-project).

- Issue History
Date Modified Username Field Change
2015-02-24 17:50 doligez New Issue
2015-02-24 17:50 doligez Status new => assigned
2015-02-24 17:50 doligez Assigned To => gasche
2015-02-25 00:02 doligez Relationship added child of 0006237
2015-02-25 00:03 doligez Note Added: 0013341
2015-04-01 16:59 doligez Note Added: 0013624
2015-04-11 19:33 gasche Note Added: 0013665
2015-04-11 19:42 gasche Note Added: 0013666
2015-04-11 19:42 gasche Status assigned => resolved
2015-04-11 19:42 gasche Fixed in Version => 4.02.2+dev / +rc1
2015-04-11 19:42 gasche Resolution open => fixed
2016-12-07 11:47 xleroy Status resolved => closed
2017-02-23 16:34 doligez Category OCamlbuild (the tool) => for ocamlbuild use https://github.com/ocaml/ocamlbuild/issues [^]
2017-02-23 16:44 doligez Category for ocamlbuild use https://github.com/ocaml/ocamlbuild/issues [^] => -for ocamlbuild use https://github.com/ocaml/ocamlbuild/issues [^]


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker