Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006802OCamlruntime system and C interfacepublic2015-03-03 16:172017-02-16 15:18
Reportererwan 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platformamd32,amd64OSdebianOS Versionwheezy
Product Version4.02.1 
Target Version4.03.0+dev / +beta1Fixed in Version4.03.0+dev / +beta1 
Summary0006802: unix and nums can not be Dynlinked together (Assert_failure in bytecomp/dll.ml)
Descriptionunix and nums can not be Dynlinked together from a toplevel

Raises
Exception: Assert_failure ("bytecomp/dll.ml", 110, 4)
Steps To Reproduceocaml
#use "topfind";;
#require "dynlink";;
#require "unix";; (* works without this #require *)
Dynlink.allow_unsafe_modules true;; (* nums requires this *)
Dynlink.loadfile "./.opam/4.02.1+PIC/lib/ocaml/nums.cma";;
Additional Informationtried also on 4.00.0, and 3.12.0

I've initially mentioned this as a note there:
http://caml.inria.fr/mantis/view.php?id=6108 [^]

But I'm unsure it's actually related.
TagsNo tags attached.
Attached Files

- Relationships
has duplicate 0006108closed Crash toplevel by using compiler-libs 

-  Notes
(0013372)
frisch (developer)
2015-03-03 16:25

I doubt the problem is related to unix and/or num, rather to the fact that Dynlink is not supported in the toplevel (as far as I know). Or can you provide an example that fails to dynlink unix and nums from a standalone program (not a toplevel)?
(0013373)
erwan (reporter)
2015-03-03 16:36

No (well, I do, but with programs that use Topmain, so I guess it does not count :).

I didn't know Dynlink was not officially supported in the toplevel, thanks for the info.

How should I know that BTW? Anyway it looks very close to work.
(0015051)
xleroy (administrator)
2015-12-06 13:01

Commit [trunk 8e6606d] causes Dynlink to fail cleanly if loaded from the toplevel loop.

- Issue History
Date Modified Username Field Change
2015-03-03 16:17 erwan New Issue
2015-03-03 16:25 frisch Note Added: 0013372
2015-03-03 16:36 erwan Note Added: 0013373
2015-03-03 21:11 doligez Status new => acknowledged
2015-03-03 21:11 doligez Target Version => 4.03.0+dev / +beta1
2015-12-05 10:58 xleroy Relationship added has duplicate 0006108
2015-12-06 13:01 xleroy Note Added: 0015051
2015-12-06 13:01 xleroy Status acknowledged => resolved
2015-12-06 13:01 xleroy Resolution open => fixed
2015-12-06 13:01 xleroy Fixed in Version => 4.03.0+dev / +beta1
2017-02-16 15:18 xleroy Status resolved => closed
2017-02-23 16:43 doligez Category OCaml runtime system => runtime system
2017-03-03 17:45 doligez Category runtime system => runtime system and C interface


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker