Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007286OCamlotherlibspublic2016-07-06 19:562017-09-24 17:33
Reportermfp 
Assigned To 
PrioritynormalSeverityminorReproducibilityrandom
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version4.02.3 
Target VersionFixed in Version4.03.0 
Summary0007286: Out-of-bounds array access in Event.sync
DescriptionI've been getting backtraces like the following on a program that uses
Event via Lwt_preemptive.detach:

    Thread 1 killed on uncaught exception Invalid_argument("index out of bounds")
    Raised by primitive operation at file "event.ml", line 93, characters 4-20
    Called from file "src/preemptive/lwt_preemptive.ml", line 79, characters 17-63
    Called from file "thread.ml", line 37, characters 8-14

The exception is raised in a Lwt_preemptive worker thread that performs this operation:

    let id, task = Event.sync (Event.receive worker.task_channel) in

(BTW. Lwt_preemptive is moving away from Event because of 0007158, but this separate
issue stands.)
TagsNo tags attached.
Attached Files

- Relationships
duplicate of 0007013closed Condition.wait inside Event is not protected against spurious wakeups 

-  Notes
(0016043)
mfp (reporter)
2016-07-06 20:23

This issue is a duplicate of 0007013, which I see has been fixed in 4.03.
(I've got no idea why searching for "Event" did not return that issue ---
I found it indirectly when I double-checked event.ml's history).

Please close.

- Issue History
Date Modified Username Field Change
2016-07-06 19:56 mfp New Issue
2016-07-06 20:23 mfp Note Added: 0016043
2016-07-07 10:08 xleroy Relationship added duplicate of 0007013
2016-07-07 10:09 xleroy Status new => resolved
2016-07-07 10:09 xleroy Resolution open => fixed
2016-07-07 10:09 xleroy Fixed in Version => 4.03.0
2017-02-23 16:42 doligez Category OCaml otherlibs => otherlibs
2017-09-24 17:33 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker